Builder Prime Payments Outage
Incident Report for Builder Prime
Resolved
Payments issues are now resolved and are fully functional.
Posted Nov 01, 2023 - 12:18 EDT
Investigating
Electronic Payment API is currently experiencing a temporary service disruption and payments may not be processed. The issue is being investigated by the development teams and we are working to resolve quickly.
Posted Nov 01, 2023 - 11:00 EDT