Outlook Performance

Incident Report for Builder Prime

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 23:36 EDT

Monitoring

Microsoft is currently experiencing Outlook issues that are affecting our integration. We are tracking their progress and will provide updates as they become available.
Posted Apr 24, 2026 - 14:53 EDT

Investigating

We are currently experiencing degraded performance with our Outlook integration.
Posted Apr 24, 2026 - 14:46 EDT
This incident affected: Web and Mobile Apps.