A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2025 - 09:41 EST
Investigating
We have intermittent reports of issues loading the signatures window. We have reached out to the service provider and are working towards a resolution for those users.
Posted Nov 25, 2025 - 09:32 EST
This incident affected: Integrations (Xodo Sign eSignature Integration).