E-signature Service Disruption

Incident Report for Builder Prime

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 12:56 EDT

Investigating

Our e-signature service provider has reported slowness and disruptions in their service. We are working to obtain an update on the service's status and fully restore it as soon as possible.
Posted Mar 17, 2025 - 12:00 EDT
This incident affected: Integrations (eversign).