ACH payment errors

Incident Report for Builder Prime

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 12:31 EDT

Identified

The issue has been identified and our partners are working on a fix right now.
Posted Mar 27, 2025 - 11:27 EDT

Investigating

We are seeing elevated errors when processing ACH payments in Builder Prime. We have escalated with our payments partners and are closely monitoring the situation.
Posted Mar 27, 2025 - 10:43 EDT
This incident affected: Web and Mobile Apps.