Application slowness and increased error rates

Incident Report for Builder Prime

Resolved

This is now resolved and we will be investigating the root cause to prevent further recurrence.
Posted Jul 27, 2026 - 16:08 EDT

Monitoring

Performance and error rates appear to have returned back to normal, but we are keeping a close watch on this.
Posted Jul 27, 2026 - 16:02 EDT

Investigating

We are working on this now and we believe we should have this resolved shortly, but will post back here soon with more updates.
Posted Jul 27, 2026 - 15:59 EDT
This incident affected: Web and Mobile Apps and API.