Issues syncing with Outlook

Incident Report for Builder Prime

Resolved

This incident has been resolved.
Posted Oct 14, 2025 - 10:21 EDT

Investigating

We are currently investigating an issue regarding syncing emails via the Outlook integration. We will update here shortly when we have found the solution.
Posted Oct 14, 2025 - 09:22 EDT
This incident affected: Integrations (Email Delivery).